download. 3D-Planner 1.6.0

minimum system requirements

To put it simply:
Your computer should not be older than 5 years and must come with a genuine graphics card, which supports premium 3d applications.


As a matter of fact the software runs on any other system, but you should face limitations in the graphical quality. If any display or graphical problems occur, please verify the topicality of your graphics card driver and install the latest one, if necessary.


recommended hardware

To achieve a smooth sense of graphical feedback, we recommend the following configuration of your computer or better:

processor:AMD Turion 64 X2 / Intel Core 2 Duo
memory:2 GB
graphics card:nVidia GeForce 8 / ATI HD2000 mit 256 MB RAM
operating system:Windows XP SP3
internet bandwidth:6 Mbit/s
BETA VERSION

Despite extensive tests it's possible that you encounter problems using this beta version of our software. To report bugs or to make suggestions on improving this software, feel free to use the built-in feedback button in the top region of the application window. Please note that we don't provide support for beta releases at the moment.
Any feedback is greatly appreciated!

minimum system requirements

imac:devices since mid 2007
mac pro:devices since begin 2008
mac book & air:devices since end 2008
mac book pro:devices since mid 2007
graphics card:NVIDIA: Geforce 8600M GT or better
ATI: Radeon HD 2600 XT or better
INTEL: HD 3000 or better
memory:2 GB
OS X Version:10.6
internet bandwidth:6 Mbit/s

additional system requirements

OS X Version:10.8 (additionally requires XQuartz)